SDB:Firefox MP4/H.264 Video Support

Aller à : navigation, rechercher

Si votre Firefox ne peut pas lire certaines vidéos HTML5, cet article peut probablement résoudre votre problème.

Solution

  1. Ajouter le dépôt Packman Essentials ou ajouter le dépôt VLC , qui contiennent un ensemble complet de bibliothèques ffmpeg/libav.
  2. Installer les paquets libavcodec56, libavcodec57, libavcodec58, libavformat56, libavformat57, libavformat58, libavdevice56, libavdevice57, libavdevice58 du dépôt Packman ou VLC. D'autres paquets libav sont également recommandés.
  3. Si vous avez déjà installé des paquets libav à partir du dépôt officiel openSUSE, passez à Packman ou VLC. Vous pouvez utiliser YaST en suivant les étapes :
    1. Rechercher, trouver et sélectionner le paquet.
    2. Ouvrir l'onglet "Version" derrière la liste des paquets.
    3. Choisissez la dernière version de Packman/VLC.
    4. En cas de problème de dépendance, choisissez la solution "Change vendor openSUSE --> Packman / VLC".
    5. Cliquez sur le bouton "Accepter" et installez les mises à jour.
  4. Redémarrez votre Firefox.
  5. Il vaudrait mieux redémarrer l'ordinateur. Au moins, pour fermer/réouvrir la session en cours.

Cette solution fonctionne très bien pour openSUSE Leap 15.0 sur HP Probook 6470b et c'est la seule qui nous permet de visionner des vidéos sur les chaînes de télévision ARTE.TV et de regarder la chaîne Eurosport player TV.

En savoir plus

MP4/H.264 devient un format vidéo largement utilisé sur Internet. De nombreux sites Web ne proposent que le format MP4 pour le flux vidéo HTML5. Donc, si votre navigateur Web ne supporte pas le codec H.264, ces vidéos ne peuvent pas être chargées ou lues.

Pour faire face aux problèmes de brevets, ni Firefox ni openSUSE ne fournit le codec H264 à supporter. C'est pourquoi votre nouvelle installation openSUSE ne peut pas lire la vidéo sur les pages Web. Heureusement, les dépôts Packman et VLC ont ces paquets utiles. Si vous avez installé des bibliothèques libav, Firefox peut les détecter sur votre système et les utiliser pour décoder la vidéo MP4/H.264.

openSUSE fournit des paquets ffmpeg/libav comme libavcodec56, mais ils sont "désactivés". Tous les codecs liés aux brevets ont été supprimés, il n'est donc pas capable de lire des vidéos MP4/H.264. C'est pourquoi vous devez mettre à jour ces paquets avec la version de Packman/VLC.

Si vous voulez savoir si votre Firefox supporte la vidéo H.264, consultez la page suivante :

Bien que Firefox ait le plugin OpenH264 (par Cisco), il n'est PAS utilisé pour décoder la vidéo HTML5.

Le plugin Firefox VLC n'a rien à voir avec la vidéo HTML5. Cela ne donne qu'une ancienne façon d'intégrer le lecteur VLC à l'intérieur des pages web.

Les plugins Firefox non officiels pour les décodeurs xine peuvent être cassés. Si vous avez des problèmes avec eux, désinstallez ces plugins et utilisez ffmpeg/libav à la place.