OpenCPN

Aller à : navigation, rechercher
OpenCPN

OpenCPNcover.png

The description of the above image

Téléchargement pour openSUSE :

Télécharger pour openSUSE


Fabricant: Open Source
Développeur: ApplicationProject
Licence: GPLv2
Web: https://opencpn.org



About

OpenCPN est un logiciel libre sous licence GPLv2 (GPLv3 pour certains plugins) qui fourni une solution complète de traceur, routage, suivi de route et de météo pour la navigation en mer. OpenCPN est developpé par de marins qui l'utilisent pour naviger les océeans sur leurs bateaux et le testent donc dans des conditions réelles.

English Site

Current release is 5.0.x

OpenCPNScreen.png


Fonctionnalités

  • support de cartes au formats BSBv3 raster and S57 ENC
  • Support des carte vectorisées CM93 support avec correction des offsets par celule.
  • Support des cartes vectorisées IHO S52 set S57
  • Affichage simple carte ou assemblées en mosaïque
  • Affichage Nort ou course en haut de l'écran
  • Glissement de cartes à l'écran
  • Calcul et suivi de route (avec prise en compte de vents et courants via un plugin)
  • Navigation vers un point d’intérêt (Waypoint)
  • Tableau de bord configurable pour afficher l'instrumentation NMEA
  • Support des GPS NMEA 0183 avec sélection de la vitesse de transmission.
  • Support d'OpenGL pour un affichage rapide.
  • Support de gpsd pour les modems plus exotiques
  • Support de l'export de route vers le pilote automatique
  • Support de l'AIS avec tracé de routes des cibles et détection de risque de colision
  • Support de l'AIS pour les fonctions for SART, DSC and GPSGate Buddies.
  • Supervision de tenu de l'ancre (et alarme si dérapage)
  • Affichage des fichiers GRIB sue la carte et prise en compte pour le routage
  • Import et export des GPX Waypoint, Route et traces.
  • Support de routage en tenant compte des marées et courants.
  • Annotation en GPX sur les cartes en mode calque.
  • Affichage des courant et marée par lieu.
  • Support multi-language
  • Un grand nombre de plugin plugins. Google Earth, World Magnetic Variation, Voyage Data Recorder, AIS -radar and a LogBook. (pré-packagé pour OpenSUSE)

Versions supportées

Versions Officielles

Elles se trouvent dans le repo Application:Geo:OpenCPN Je fourni des packages pour:

  • OpenSUSE Leap 42.2 (Ceci est la version préférée et la seule testée en mer)
  • OpenSUSE Leap 42.1 (NOTE Vous devez déactiver OpenGL "Configuration>Display>General>Advance" sous peine d'avoir des problèmes avec certains plugins)
  • OpenSUSE Tumbleweed n'est pas supportée vous trouverez des packages dans ma sandbox "home:dominig:opencpn-sandbox" au cas où vous voudriez vous entraîner à la maison.

Note: Pour des raison de test et validation, je ne fourni pas (et ne fournirai pas) de version pour la running release (Tumbleweed)

32 Bits Legacy

Je ne fourni plus de version 32 bits. Si wous avez un vieil Atom qui ne supporte pas le 64 bits, il ne vous reste que les versions "Legacy"


Plugins

Liste des plugins compatibles avec Linux

Installation

L’installation sous Linux OpenSUSE est très simple car tout est packagé pour le support du 1-Click install.

  1. Installer la dernière version stable d'OpenSUSE sur votre PC si ce n'est pas déjà fait.
    1. Lien Téléchargement et Howto
    2. Video
  2. One click install
    1. Lancer le navigateur Firefox (car il supporte la fonction one-Click install)
    2. Chercher la version qui convient à votre version d'OpenSUSE OpenCPN Search
    3. Choisir la version Stable officielle dont l'origine Application:Geo:OpenCPN
    4. Clicker le lien 1-Click install
    5. Accepter l'installation. Votre mot de passe pour root vous sera demandé (la première installation est assez longue car il y a de gros fichier de data à télécharger. Il vaut mieux le faire avec le Wifi du port qu'en mer).

Anciennes versions

upgrade de 4.0/4.4 en 4.6

Du au fait que certains plugins aient été intégrés dans le logiciel principal d'OpenCPN certains noms de paquets ont changé et certains ont disparu, il est donc plus simple de supprimer OpenCPN-4.x et tous les paquets associés dans une première phase. Puis d'installer la nouvelles version de OpenCPN-4.x qui tirera automatiquement les dépendances.

Erreur WX "...WXU_3.0 not defined in file libw ..."

Selon la version et la configuration de votre OpenSUSE, il est possible que vous deviez installer la version des libwx nostl3 provenant du repo X11:wxWidgets.

Dans ce cas vous verrez l'erreur suivante (ou similaire):

 ~$ opencpn 
 opencpn: relocation error: opencpn: symbol _ZTV21wxwxSizerItemListNode, version WXU_3.0 not defined in file libwx_gtk2u_core-suse.so.1 with link time reference

Note: Cette erreur peut aparaitre uniquement lors de l'activation d'un plugin.

Dans tous les cas il faut replacer les paquets wx nostl par ceux de la repo X11. Les paquets fourni par la repo Packman ne conviennent pas.

  • démarrer Yast
  • chercher nostl3
  • changer la source pour obs://build.opensuse/x11

Pour OpenCPN Legacy 4.0/4.4 voir le fichier Fichier:OpenCPN-WX3-HowTo.pdf

Autres liens

En Français

In English