The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

openSUSE:GNOME 3.0

(Redirigé depuis GNOME3)
Aller à : navigation, rechercher

GNOME 3.0 dans openSUSE 11.4

openSUSE 11.4 a été construite avec GNOME 2.32, mais nous savons que les gens veulent profiter de l'élégante interface de GNOME 3. Donc l'équipe de GNOME a travaillé dur pour fournir GNOME 3.0 pour openSUSE 11.4. Nous savons que vous l'aimerez.

Comment mettre à jour openSUSE 11.4 vers GNOME 3.0

SVP lisez les instructions attentivement avant de faire la mise à jour.

Installation en un clic

D'abord, soyez sûr d'ouvrir un terminal avant de commencer la procédure de mise à jour (vous en aurez besoin pour redémarrer votre système quand la mise à jour sera finie), et fermez toutes les autres applications en cours.

Utilisez le bouton d'installation en un clic ci-dessous:

Pour openSUSE 11.4 x86 32bit
Oneclick.png
Pour openSUSE 11.4 x86 64bit
Oneclick.png

Suivez les instructions que vous aurez à l'écran. Quand la procédure de mise à jour sera finie, dans le terminal ouvert avant de commencer la mise à jour, redémarrez le système:

$ sudo /sbin/reboot

Si vous avez oublié d'ouvrir un terminal, faites un clic droit sur le fond d'écran du bureau et choisissez "Ouvrir un terminal" pour en ouvrir un.

Mise à jour Texte

Si vous préferez utiliser une mise à jour texte, faites ce qui suit (en root), après avoir fermé toutes les applications en cours:

  • ajouter le dépot GNOME:STABLE:3.0
    # zypper ar obs://GNOME:STABLE:3.0/openSUSE_11.4 GNOME_STABLE_3.0
  • assurez-vous d'activer le rafraîchissement automatique et de lui donner une plus grande priorité que les autres dépots openSUSE 11.4
    # zypper mr -p 98 -r GNOME_STABLE_3.0
  • faites la mise à jour (fermez toutes les applications en cours auparavant):
    # zypper dup
  • quand la mise à jour est terminée, redémarrez votre système:
    $ sudo /sbin/reboot

FAQ

J'ai mis à jour vers GNOME 3.0, mais j'ai un problème. Où dois je le rapporter?
SVP remplissez un rapport de bug sur openSUSE 11.4 et mettez [gnome3] dans le résumé du bug.

J'ai installé l'image live (openSUSE) avec GNOME 3 sur ma machine, que dois-je faire pour avoir les dernières mises à jours?
Vous devriez changer le dépot qui fournissait GNOME 3 vers GNOME:STABLE:3.0. Voilà comment faire ça (en root):

  • ajouter le dépot GNOME:STABLE:3.0 à votre système :
    # zypper ar obs://GNOME:STABLE:3.0/openSUSE_11.4 GNOME_STABLE_3.0
  • assurez-vous d'activer le rafraichissement automatique et de donner une priorité plus importante que les autres dépots openSUSE 11.4 :
    # zypper mr -p 98 -r GNOME_STABLE_3.0
  • enlevez l'ancien dépot :
    # zypper rr home:fcrozat:gnome3_11.4
  • mettez à jour votre système avec le nouveau dépot:
    # zypper dup
  • redémarrez votre système (parce que beaucoup de librairie changent durant la mise à jour)


Problèmes connus

  • GNOME Shell nécessite le support de la 3D (openGL) qui n'est pour l'instant pas assez stable dans VirtualBox ou VMWare. Nous recommandons de désactiver le support de la 3D dans ces environnements et d'utiliser le mode "Fallback" de GNOME 3 à la place (il sera séléctionné automatiquement).
  • NetworkManager 0.9, requis par GNOME 3, contient pour l'instant les problèmes suivants :
    • KDE 4 ne détectera pas correctement la disponibilité des réseaux : vous devriez choisir la "méthode traditionnel avec ifup" dans les paramètres de réseau Yast, ou utilisez nm-applet (disponible dans le paquet NetworkManager-gnome) dans KDE. Ce problème sera résolu dans la prochaine version d'openSUSE.
    • Editer et activer les réseaux wifi WPA-Entreprise n'est pas disponible dans l'extension réseau de GNOME Shell ou le Centre de Controle du Réseau de GNOME. Ce problème sera résolu rapidement.
    • le support de novellvpn n'est pas disponible : ce problème est en cours d'examen.
    • le mot de passe root est demandé quand on configure un compte WEP/WPA.
  • la configuration de la connexion automatique dans le panneau du compte utilisateur est incorrecte. Jusqu'à ce que ce problème soit résolu, utilisez yast (Gestion des utilisateurs et des ggroups / Options Avancées / Paramètres de connexion / Connexion automatique) https://bugzilla.novell.com/show_bug.cgi?id=688071
  • le mot de passe root est demandé quand les dépots sont mis à jours pour tester si des mises à jours de sécurité sont disponibles.

Comment Aider?

Vous pouvez aider en:

  • testant et rapportant les problèmes.
  • aider au tri des bugs connus
  • aider les gens qui mettent à jour et rapporter les problèmes dans les forums